Unknown heat source in heat transfer-laminar flow coupled model

Thread index  |  Previous thread  |  Next thread  |  Start a new discussion

RSS FeedRSS feed   |   Email notificationsTurn on email notifications   |   1 Reply   Last post: April 8, 2013 5:09am UTC
Adam Curry

Adam Curry

April 7, 2013 9:36pm UTC

Unknown heat source in heat transfer-laminar flow coupled model

Hi all,

I am modeling a volcanic conduit (5 m wide) moving up through a "host rock." I want to analyze the thermal budget of this situation. The conduit is a rectangle (Heat Transfer in Fluids, Laminar Flow) between two other rectangles (just Heat Transfer in Solids). I want to make sure I understand what COMSOL is doing in the basic situations before I add in other heat sources and parameters, etc. I am running the basic COMSOL package. With this in mind, I have two questions:

First I constructed a model with both heat transfer and laminar flow. I set up all necessary parameters and values. I then ran the model with each physics one at a time. This was just to make sure each physics was doing what it is supposed to. For the laminar flow, I calculated the analytical solution for the maximum velocity and the flux. These values match fairly well with the COMSOL values. For the model run with just Heat Transfer (in both solids and fluids), I expected the conduit temperature to decrease with time. The laminar flow is turned off, and there is no other heat source (so I thought). I am using the basic COMSOL package, so viscous heating is not taken into account (and laminar flow is turned off anyway), and I added no 'Heat Source'. So, the conduit should be simply cooling by conduction to the surrounding "rock." But, the 2D Temperature Surface plot shows an increase from the initial 1123.15 K of the conduit to 1138.7 K.

Question 1: Where is this heat coming from?

Second, I ran the model with both physics (Heat Transfer and Laminar Flow) on together. I checked the laminar flow with the analytical solution, and it worked out. However, this model produced an even greater temperature increase. The temperature rose to 1191.5 K (again from a starting temperature of 1123.15). Again, I did not put in a 'Heat Source', and the basic COMSOL does not take into account viscous heating. So, I expected the temperature to decrease due to heat loss to the surrounding "rock."

Question 2: Where is this heat coming from? I did not set anything in the model to a temperature above 1123.15. Does the laminar flow produce some heat by default?

I appreciate any insight anyone has into this.

Thanks!
Adam

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse

Ivar Kjelberg

Ivar Kjelberg

April 8, 2013 5:09am UTC in response to Adam Curry

Re: Unknown heat source in heat transfer-laminar flow coupled model

Hi

sometimes the change in T can come from "smoothing" in the post processing, and is also related to mesh densities.

I posted a "quiz" some weeks ago, with an example. I must have made it to complex as nobody reacted on it, but is shows what happens when mesh density and too simple initial conditions are applied.

Some people are convinced COMSOL is wrong because of this, but COMSOL calculates correctly it's the model set up and the numerics only that make these effects and that is the user responsability


see: www.comsol.eu/community/forums/general/thread/35651/

--
Good luck
Ivar

Reply  |  Reply with Quote  |  Send private message  |  Report Abuse


Rules and guidelines